欢迎来到股票分析软件——威尼斯人注册平台官网

当前位置:股票软件 > 投资知识 > 股票知识 > 正文

【股票知识】VOL地量指标公式源码解说

编辑:威尼斯人注册平台

2016-11-17 10:28:08

  量、价、时、空是分析股票价格以及行情发展的四大因素,其中量能和价格是最重要的两个判断因素,投资者可以通过股票走势软件进行个股分析,那么当成交量出现地量的时候应该怎样分析,可以借助vol地量指标的股票公式进行分析。

  在个股的日线走势图中,每一根K线都对应一根量柱,通过量价分析,研判股价的的上涨趋势与形态,其VOL地量指标公式如下:

  {V1:=CLOSE/REF(CLOSE,3)>=1.1;

  V2:=BACKSET(V1,2);}

  {红柱信号:V2 AND COUNT(V2,2)=1;

  DRAWTEXT(V2 AND COUNT(V2,2)=1,0.5,'红柱信号为1'),COLORFFFF00;}

  VVOL:=IF(CURRBARSCOUNT=1 AND PERIOD=5,VOL*240/FROMOPEN,DRAWNULL);{模拟量}

  STICKLINE(CURRBARSCOUNT=1 AND PERIOD=5,VVOL,0,3,-1),COLOR00C0C0;

  VOL,VOLSTICK;

  倍量:(VOL/REF(VOL,1)>2 AND COUNT(CLOSE>OPEN,1)) OR (LOW>REF(HIGH,1) AND COUNT(OPEN>CLOSE,1) AND VOL/REF(VOL,1)>2),COLORFF00FF;

  STICKLINE(倍量,0,V,3,0),COLORFF00FF;

  地量:LLV(VOL,15)=VOL,COLORWHITE;

  STICKLINE(地量,0,V,1,0),COLORWHITE;

  三十地:LLV(VOL,30)=VOL,COLORFFDE00;

  STICKLINE(三十地,0,V,3,0),COLOR008800;

  倍缩量:VOL/REF(VOL,1)<0.5,COLORYELLOW;

  STICKLINE(倍缩量,0,V,3,0),COLORYELLOW;

  缩量涨:COUNT(C>REF(C,1),2)=2 AND COUNT(VOL

  STICKLINE(缩量涨,0,V,3,0),COLORGREEN;

  黑跳: IF(LOW>REF(HIGH,1) AND COUNT(OPEN>CLOSE,1),0.5,0),COLORFF0080;

  STICKLINE(黑跳,0,V,3,0),COLORFF0080;

  红跳:IF(LOW>REF(HIGH,1) AND COUNT(OPEN< p=""><>

  STICKLINE(红跳,0,V,3,0),COLOR8000FF;

  真阳或假阴:=C>O OR C>REF(C,1);

  收阳:= REF(真阳或假阴,3);

  倍量1:=REF(倍量,3);

  高量:=REF(V,3)>=HHV(V,7);

  三日不破:= LLV(C,3)>=REF(L,3);

  价升:=COUNT(C>=REF(C,1),3)=3;{收盘价逐升}

  量缩:=COUNT(V<=REF(V,1),3)=3;

  连阳:= COUNT(真阳或假阴,3)=3;

  倍量将军柱:= 倍量1 AND 三日不破 AND 收阳;

  高量将军柱:= 高量 AND 三日不破 AND 收阳;

  将军柱:= 倍量将军柱 OR 高量将军柱;

  黄金柱:将军柱 AND 价升 AND 量缩 AND 连阳 ,COLOR0077FF;

  DRAWICON(黄金柱,V+0.1,1);

  长阴短柱:C/REF(C,1)<=0.96 AND V<hhv(v,30) p="" 1.9;<="">

  DRAWTEXT(长阴短柱 ,V,'!'),COLORLICYAN;

  XGX7:=ABS((VOL-REF(VOL,7))/REF(VOL,7))<0.04 AND

  VOL>1.8*REF(VOL,2) AND

  REF(VOL,1)<ref(vol,7) p="" and<="">

  REF(VOL,2)<ref(vol,7) p="" and<="">

  REF(VOL,3)<ref(vol,7) p="" and<="">

  REF(VOL,(7-3))<ref(vol,7) p="" and<="">

  REF(VOL,(7-2))<ref(vol,7) p="" and<="">

  REF(VOL,(7-1))< p=""><>

  XGX8:=ABS((VOL-REF(VOL,8))/REF(VOL,8))<0.04 AND

  VOL>1.8*REF(VOL,2) AND

  REF(VOL,1)<ref(vol,8) p="" and<="">

  REF(VOL,2)<ref(vol,8) p="" and<="">

  REF(VOL,3)<ref(vol,8) p="" and<="">

  REF(VOL,(8-3))<ref(vol,8) p="" and<="">

  REF(VOL,(8-2))<ref(vol,8) p="" and<="">

  REF(VOL,(8-1))< p=""><>

  XGX9:=ABS((VOL-REF(VOL,9))/REF(VOL,9))<0.04 AND

  VOL>1.8*REF(VOL,2) AND

  REF(VOL,1)<ref(vol,9) p="" and<="">

  REF(VOL,2)<ref(vol,9) p="" and<="">

  REF(VOL,3)<ref(vol,9) p="" and<="">

  REF(VOL,(9-3))<ref(vol,9) p="" and<="">

  REF(VOL,(9-2))<ref(vol,9) p="" and<="">

  REF(VOL,(9-1))< p=""><>

  XGX10:=ABS((VOL-REF(VOL,10))/REF(VOL,10))<0.04 AND

  VOL>1.8*REF(VOL,2) AND

  REF(VOL,1)<ref(vol,10) p="" and<="">

  REF(VOL,2)<ref(vol,10) p="" and<="">

  REF(VOL,3)<ref(vol,10) p="" and<="">

  REF(VOL,(10-3))<ref(vol,10) p="" and<="">

  REF(VOL,(10-2))<ref(vol,10) p="" and<="">

  REF(VOL,(10-1))< p=""><>

  XGX11:=ABS((VOL-REF(VOL,11))/REF(VOL,11))<0.04 AND

  VOL>1.8*REF(VOL,2) AND

  REF(VOL,1)<ref(vol,11) p="" and<="">

  REF(VOL,2)<ref(vol,11) p="" and<="">

  REF(VOL,3)<ref(vol,11) p="" and<="">

  REF(VOL,(11-3))<ref(vol,11) p="" and<="">

  REF(VOL,(11-2))<ref(vol,11) p="" and<="">

  REF(VOL,(11-1))< p=""><>

  XGX12:=ABS((VOL-REF(VOL,12))/REF(VOL,12))<0.04 AND

  VOL>1.8*REF(VOL,2) AND

  REF(VOL,1)<ref(vol,12) p="" and<="">

  REF(VOL,2)<ref(vol,12) p="" and<="">

  REF(VOL,3)<ref(vol,12) p="" and<="">

  REF(VOL,(12-3))<ref(vol,12) p="" and<="">

  REF(VOL,(12-2))<ref(vol,12) p="" and<="">

  REF(VOL,(12-1))< p=""><>

  DRAWTEXT(XGX7,V,'7日平量柱'),COLORFFFF00;

  DRAWTEXT(XGX8,V,'8日平量柱'),COLORFFFF00;

  DRAWTEXT(XGX9,V,'9日平量柱'),COLORFFFF00;

  DRAWTEXT(XGX10,V,'10日平量柱'),COLORFFFF00;

  DRAWTEXT(XGX11,V,'11日平量柱'),COLORFFFF00;

  DRAWTEXT(XGX12,V,'12日平量柱'),COLORFFFF00;

  百日地量:LLV(VOL,100)=VOL,COLORWHITE;

  STICKLINE(百日地量,0,V,3,0),COLORWHITE;

  V1:=CLOSE/REF(CLOSE,3)>=1.1;

  V2:=BACKSET(V1,2);

  V3:=REF(CLOSE,3)*1.1;

  V4:=CROSS(C,V3);

  STICKLINE((V2 AND COUNT(V2,2)=1),VOL,0,3,0),COLOR00007D;

  STICKLINE((V2 AND COUNT(V2,2)=1),VOL,0,2.4,0),COLOR0000A6;

  STICKLINE((V2 AND COUNT(V2,2)=1),VOL,0,2,0),COLOR0000BB;

  STICKLINE((V2 AND COUNT(V2,2)=1),VOL,0,1.4,0),COLOR0000DD;

  STICKLINE((V2 AND COUNT(V2,2)=1),VOL,0,0.8,0),COLOR0000FF;

  M5:MA(VOL,5),COLORFFFFFF;

  M20:MA(VOL,20);

  M55:MA(VOL,55),COLORGREEN,LINETHICK2;

  DRAWICON(CROSS(V,M5) AND CROSS(V,M20) AND C > O,L*0.95,5);

  从以上的源码中能够看出,成交量柱有平量柱,将军柱、倍量柱、百日地量群,等等,当形成百日地量群的时候,个股的走势可能是处于吸筹的状态,其中的操作技巧,希望投资者能够把握好其中的操作机会。更多的精彩内容或者想要学习一套完善的操作体系,请点击江恩理论,进行研究学习。


威尼斯人注册平台财富网  www.360gann.com

XML 地图 | Sitemap 地图